Outcome Reports delays.
Incident Report for ReferAll Ltd
Resolved
We are confident that this issue was resolved promptly
Posted 24 days ago. Sep 25, 2019 - 14:48 UTC
Investigating
Dear All
We are actively looking into delays with Outcome Reporting, and will advise when we have investigated this thoroughly. In the meantime we are just making you aware that there is an issue and it is in hand.
Kind Regards Refer-All Support
Posted about 2 months ago. Aug 27, 2019 - 10:01 UTC